# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"#(?!:[\w]+)(?=([\w\d\[\]\,\*\=\>\.\s]*[\{\,\[]+))"
test_str = ("div#xyz, #xyz, div#xyz[id='xyz'],\n"
" .def>#xyz, .def>div#xyz, .def>#xyz,\n"
" .def>div#xyz[id=*]{\n"
" color:#ee2ee2;\n"
"}\n\n\n"
"@media (min-width: 30em) and (orientation: landscape) \n"
"{\n"
" .abc{\n"
" background-color :#FFFFFF;\n"
" border-color:1px solid #eee ;\n"
" }\n\n"
" .def>#xyz, .def #xyz, .def>#xyz{border-color:1px solid #ddd;}\n"
"}")
subst = "."
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.