import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\=).+?((?=\\t)|(?=\\n))";
final String string = "=friction_t1!$B$2abc =friction_t1!$B$3 =friction_t1!$B$4\n"
+ "=friction_t2!$B$2 =friction_t2!$B$3 =friction_t2!$B$4\n"
+ "=friction_t3!$B$2 =friction_t3!$B$3 =friction_t3!$B$4\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}