re = /(?<=\=).+?((?=\t)|(?=\n))/m
str = '=friction_t1!$B$2abc =friction_t1!$B$3 =friction_t1!$B$4
=friction_t2!$B$2 =friction_t2!$B$3 =friction_t2!$B$4
=friction_t3!$B$2 =friction_t3!$B$3 =friction_t3!$B$4
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end