$re = '/\b(\d+)\1+\b/mi';
$str = '11111111, 2222, 99999999999,123123123
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);