$re = '/ +$/m';
$str = 'n = 10
for i in range(n):
print(i) ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);