using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(src|href)(\s*=\s*)([""'])(.+(?=\s).+)\3";
string input = @"<iframe src=""http://some.url"" width=""600px"" ></iframe>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}