re = /(src|href)(\s*=\s*)(["'])(.+(?=\s).+)\3/
str = '<iframe src="http://some.url" width="600px" ></iframe>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end