using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"elevator openings vo (f\d*) (\d*)";
string input = @"elevator openings vo f1 2
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}