package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`elevator openings vo (f\d*) (\d*)`)
var str = `elevator openings vo f1 2
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}