package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:https://|http://)?([\w\.]+)/?`)
var str = `www.w3.org/
https://www.w3.org/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}