re = /(?:https:\/\/|http:\/\/)?([\w\.]+)\/?/
str = 'www.w3.org/
https://www.w3.org/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end