using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d[,\d]*(?=\s*visits)";
string input = @"<meta name=""description"" content=""‎ST. Eye Clinic - عيادة دكتور محمد عزب لطب و جراحة العيون‎, Dumyat Al Jadidah, Dumyat, Egypt. 20,956 visits ·
<meta name=""description"" content=""ABC. 2,894,865 visits ·";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}