re = /\d[,\d]*(?=\s*visits)/i
str = '<meta name="description" content="‎ST. Eye Clinic - عيادة دكتور محمد عزب لطب و جراحة العيون‎, Dumyat Al Jadidah, Dumyat, Egypt. 20,956 visits ·
<meta name="description" content="ABC. 2,894,865 visits ·'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end