$re = '/(?P<function>st\([\"\'])(?P<string>.+?(?=[\"\'](\s*,ctx\s*|\s*,\s*)))/m';
$str = 'let nlabel = rs.length ? st(\'string1\', [st(\'string2\', ctx = \'ctx2\')], ctx = \'ctx1\') : st(\'Found {0}\', [st(this.param)], ctx = \'ctxparam\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);