re = /(?P<function>st\([\"'])(?P<string>.+?(?=[\"'](\s*,ctx\s*|\s*,\s*)))/m
str = 'let nlabel = rs.length ? st(\'string1\', [st(\'string2\', ctx = \'ctx2\')], ctx = \'ctx1\') : st(\'Found {0}\', [st(this.param)], ctx = \'ctxparam\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end