$re = '~\w[,.?\']\w(*SKIP)(*FAIL)|[,.?\']~';
$str = 'Hello, Harry Potter. I\'m Tom Riddle.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);