re = /\w[,.?']\w(*SKIP)(*FAIL)|[,.?']/
str = 'Hello, Harry Potter. I\'m Tom Riddle.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end