import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<name>.+?)\\/(?P<version>.+?) \\(Kiwi\\.com (?P<environment>.+?)\\)(?: ?(?P<system_info>.*))$";
final String string = "mambo/87f2594 (Kiwi.com production)\n"
+ "flights/b5bf54c32a112273245543a9eac0afdb8d8b32a5 (Kiwi.com rkuska-dev) requests/2.16.3 python/2.7.15";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}