// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?P<name>.+?)\/(?P<version>.+?) \(Kiwi\.com (?P<environment>.+?)\)(?: ?(?P<system_info>.*))$").unwrap();
let string = "mambo/87f2594 (Kiwi.com production)
flights/b5bf54c32a112273245543a9eac0afdb8d8b32a5 (Kiwi.com rkuska-dev) requests/2.16.3 python/2.7.15";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}