$re = '/(vif\W+)?((?:, )?\'mac=00:21:f6:)((\w{2}:?){3})(,bridge=\w+\')(?:])?/m';
$str = 'vif = [\'mac=00:21:f6:04:16:f3,bridge=101498d8ff\', \'mac=00:21:f6:80:0b:d9,bridge=1017dc5841\']';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);