re = /(vif\W+)?((?:, )?'mac=00:21:f6:)((\w{2}:?){3})(,bridge=\w+')(?:])?/m
str = 'vif = [\'mac=00:21:f6:04:16:f3,bridge=101498d8ff\', \'mac=00:21:f6:80:0b:d9,bridge=1017dc5841\']'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end