re = /^[a-z]+:\/\/[^\/,#?]*\K[^,\n]*/m
str = 'https://community.domain.tld/register?to=3662%2354564894861351532416dzda#%frfgrzfz,categorie,dateAcces,,,
https://community.domain.tld/register?tests,categorie,dateAcces,,,
https://community.domain.tld/register,categorie,dateAcces,,,
https://community.domain.tld/,categorie,dateAcces,,,
https://community.domain.tld,categorie,dateAcces,,,
https://community.domain.tld?to=dfgdfgdgf,categorie,dateAcces,,,
https://community.domain.tld#dfgdfgdgf,categorie,dateAcces,,,
https://community.domain.tld,categorie,dateAcces,,,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end