package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[A-Za-z0-9._%+-]+@[A-Za-z0-9.-]+\.[A-Za-z]{2,}\b`)
var str = `test@example.com
test@users.example.com
test@hexample.com
test@regex101.com
test@example.co`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}