re = /\b[A-Za-z0-9._%+-]+@[A-Za-z0-9.-]+\.[A-Za-z]{2,}\b/m
str = 'test@example.com
test@users.example.com
test@hexample.com
test@regex101.com
test@example.co'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end