import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s(\\w{1,}):\\s+((?:\\w\\w\\s)+)\\s+(\\w+)(.*)";
final String string = " 6bb: c3 ret \n"
+ " 6bc: 0f 1f 40 00 nop DWORD PTR [rax+0x0]\n"
+ " 6c0: 41 57 push r15\n"
+ " 6c2: 41 56 push r14\n"
+ " 6c4: 41 89 ff mov r15d,edi\n"
+ " 6c7: 41 55 push r13\n"
+ " 6c9: 41 54 push r12\n"
+ " 6cb: 4c 8d 25 06 07 20 00 lea r12,[rip+0x200706] # 0x200dd8\n"
+ " 6d2: 55 push rbp\n"
+ " 6d3: 48 8d 2d 06 07 20 00 lea rbp,[rip+0x200706] # 0x200de0\n"
+ " 6da: 53 push rbx\n"
+ " 6db: 49 89 f6 mov r14,rsi\n"
+ " 6de: 49 89 d5 mov r13,rdx\n"
+ " 6e1: 4c 29 e5 sub rbp,r12\n"
+ " 6e4: 48 83 ec 08 sub rsp,0x8\n"
+ " 6e8: 48 c1 fd 03 sar rbp,0x3\n"
+ " 6ec: e8 3f fe ff ff call 0x530\n"
+ " 6f1: 48 85 ed test rbp,rbp\n"
+ " 6f4: 74 20 je 0x716\n"
+ " 6f6: 31 db xor ebx,ebx\n"
+ " 6f8: 0f 1f 84 00 00 00 00 nop DWORD PTR [rax+rax*1+0x0]\n"
+ " 6ff: 00 \n"
+ " 700: 4c 89 ea mov rdx,r13\n"
+ " 703: 4c 89 f6 mov rsi,r14\n"
+ " 706: 44 89 ff mov edi,r15d\n"
+ " 709: 41 ff 14 dc call QWORD PTR [r12+rbx*8]\n"
+ " 70d: 48 83 c3 01 add rbx,0x1\n"
+ " 711: 48 39 dd cmp rbp,rbx\n"
+ " 714: 75 ea jne 0x700\n"
+ " 716: 48 83 c4 08 add rsp,0x8\n"
+ " 71a: 5b pop rbx\n"
+ " 71b: 5d pop rbp\n"
+ " 71c: 41 5c pop r12\n"
+ " 71e: 41 5d pop r13\n"
+ " 720: 41 5e pop r14\n"
+ " 722: 41 5f pop r15\n"
+ " 724: c3 ret \n"
+ " 725: 90 nop\n"
+ " 726: 66 2e 0f 1f 84 00 00 nop WORD PTR cs:[rax+rax*1+0x0]\n"
+ " 72d: 00 00 00 \n"
+ " 730: f3 c3 repz ret \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}