import Foundation
let pattern = #"^\s(\w{1,}):\s+((?:\w\w\s)+)\s+(\w+)(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
6bb: c3 ret
6bc: 0f 1f 40 00 nop DWORD PTR [rax+0x0]
6c0: 41 57 push r15
6c2: 41 56 push r14
6c4: 41 89 ff mov r15d,edi
6c7: 41 55 push r13
6c9: 41 54 push r12
6cb: 4c 8d 25 06 07 20 00 lea r12,[rip+0x200706] # 0x200dd8
6d2: 55 push rbp
6d3: 48 8d 2d 06 07 20 00 lea rbp,[rip+0x200706] # 0x200de0
6da: 53 push rbx
6db: 49 89 f6 mov r14,rsi
6de: 49 89 d5 mov r13,rdx
6e1: 4c 29 e5 sub rbp,r12
6e4: 48 83 ec 08 sub rsp,0x8
6e8: 48 c1 fd 03 sar rbp,0x3
6ec: e8 3f fe ff ff call 0x530
6f1: 48 85 ed test rbp,rbp
6f4: 74 20 je 0x716
6f6: 31 db xor ebx,ebx
6f8: 0f 1f 84 00 00 00 00 nop DWORD PTR [rax+rax*1+0x0]
6ff: 00
700: 4c 89 ea mov rdx,r13
703: 4c 89 f6 mov rsi,r14
706: 44 89 ff mov edi,r15d
709: 41 ff 14 dc call QWORD PTR [r12+rbx*8]
70d: 48 83 c3 01 add rbx,0x1
711: 48 39 dd cmp rbp,rbx
714: 75 ea jne 0x700
716: 48 83 c4 08 add rsp,0x8
71a: 5b pop rbx
71b: 5d pop rbp
71c: 41 5c pop r12
71e: 41 5d pop r13
720: 41 5e pop r14
722: 41 5f pop r15
724: c3 ret
725: 90 nop
726: 66 2e 0f 1f 84 00 00 nop WORD PTR cs:[rax+rax*1+0x0]
72d: 00 00 00
730: f3 c3 repz ret
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)