package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?x)(\[QUOTE[^][]*\]
(?:[^][]++|(?1))++
\[/QUOTE\])`)
var str = `QUOTE]
This is a a valid quote, as it's only 1 level deep.
[QUOTE="User 2"]
Here's an unnecessary nested quote.
[QUOTE]
Here's a 3nd level unnecessary nested quote.
[/QUOTE]
[/QUOTE]
[/QUOTE]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}