$re = '~(\[QUOTE[^][]*\]
(?:[^][]++|(?1))++
\[/QUOTE\])~x';
$str = 'QUOTE]
This is a a valid quote, as it\'s only 1 level deep.
[QUOTE="User 2"]
Here\'s an unnecessary nested quote.
[QUOTE]
Here\'s a 3nd level unnecessary nested quote.
[/QUOTE]
[/QUOTE]
[/QUOTE]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);