package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([1-9]{1}[0-9]+)[.]?[0-9]+`)
var str = `1
12
123
1.1
12.1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}