$re = '/([1-9]{1}[0-9]+)[.]?[0-9]+/m';
$str = '1
12
123
1.1
12.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);