package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)d+a+y+`)
var str = `Day
Dday
Daay
Dayy
Ddaay
Ddayy`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}