$re = '/d+a+y+/i';
$str = 'Day
Dday
Daay
Dayy
Ddaay
Ddayy';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);