#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=[a-zA-Z0-9])^[\w-\.]+[A-Za-z0-9]@[\w-]+\.([\w-]+\w\.){0,}[A-Za-z]{2,6}$"
Local $sString = "mail@mail.ru" & @CRLF & _
"mail88@gmail.com" & @CRLF & _
"mail__@mail.com" & @CRLF & _
"1anonimus2@mail.ru" & @CRLF & _
"_mail@mail.ru" & @CRLF & _
"mail-asda@mail.gmail101-.hremail.com" & @CRLF & _
"mail-asda@mail.gmail101-102.hremail.com" & @CRLF & _
"mail-t.comail.mail@mail.com" & @CRLF & _
"mail-t.comail.mail.@mail.com" & @CRLF & _
"" & @CRLF & _
"mail-t.comail.mail@mail.com."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")