const regex = /(?=[a-zA-Z0-9])^[\w-\.]+[A-Za-z0-9]@[\w-]+\.([\w-]+\w\.){0,}[A-Za-z]{2,6}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=[a-zA-Z0-9])^[\\w-\\.]+[A-Za-z0-9]@[\\w-]+\\.([\\w-]+\\w\\.){0,}[A-Za-z]{2,6}$', 'gm')
const str = `mail@mail.ru
mail88@gmail.com
mail__@mail.com
1anonimus2@mail.ru
_mail@mail.ru
mail-asda@mail.gmail101-.hremail.com
mail-asda@mail.gmail101-102.hremail.com
mail-t.comail.mail@mail.com
mail-t.comail.mail.@mail.com
mail-t.comail.mail@mail.com.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}