package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^b*(?:(?:ab*){3})*$`)
var str = `bbabbbabba
aaa
ababa
babbbbabbbba
aab
bbb`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}