$re = '/^b*(?:(?:ab*){3})*$/m';
$str = 'bbabbbabba
aaa
ababa
babbbbabbbba
aab
bbb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);