import re
regex = re.compile(r"(?<=<ID>)(\d+)(?=<VAL>)|(?<=<VAL>)[a-z\d]*(?=<ID>)", flags=re.MULTILINE)
test_str = "<ID>0<VAL>a1b<ID>1<VAL>a2b<ID>2<VAL>a3b<ID>3<VAL>a4b"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")