re = /(?<=<ID>)(\d+)(?=<VAL>)|(?<=<VAL>)[a-z\d]*(?=<ID>)/m
str = '<ID>0<VAL>a1b<ID>1<VAL>a2b<ID>2<VAL>a3b<ID>3<VAL>a4b'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end