package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\h*(.*?\[(?:youtube|instagram)\h+id=[^][\s]+])`)
var str = `i want to show you my youtube channel : [youtube id=12341234] and my instagram account : [instagram id=myingaccount213]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}