$re = '/\h*(.*?\[(?:youtube|instagram)\h+id=[^][\s]+])/m';
$str = 'i want to show you my youtube channel : [youtube id=12341234] and my instagram account : [instagram id=myingaccount213]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);