#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!CG.*AG.*AG)CG.*AG$"
Local $sString = "CGUUAG" & @CRLF & _
"CGCGUCAG" & @CRLF & _
"AGUCGUAG" & @CRLF & _
"CGAGAG" & @CRLF & _
"UUAGAGCUUAGC" & @CRLF & _
"CGCGCGAG" & @CRLF & _
"CGAG" & @CRLF & _
"AAGCCU" & @CRLF & _
"GACU"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")