#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?msi)(\w*\(Hex\): w*)(.*?)(?= |$)"
Local $sString = " Vserver Name: vs1" & @CRLF & _
" LUN Path: /vol/vol1/lun1" & @CRLF & _
" Volume Name: vol1" & @CRLF & _
" Qtree Name: """ & @CRLF & _
" LUN Name: lun1" & @CRLF & _
" LUN Size: 10MB" & @CRLF & _
" OS Type: linux" & @CRLF & _
" Space Reservation: disabled" & @CRLF & _
" Serial Number: wCVt1]IlvQWv" & @CRLF & _
" Serial Number (Hex): 77435674315d496c76515776" & @CRLF & _
" Comment: new comment" & @CRLF & _
"Space Reservations Honored: false" & @CRLF & _
" Space Allocation: disabled" & @CRLF & _
" State: offline" & @CRLF & _
" LUN UUID: 76d2eba4-dd3f-494c-ad63-1995c1574753" & @CRLF & _
" Mapped: mapped" & @CRLF & _
" Block Size: 512" & @CRLF & _
" Device Legacy ID: -" & @CRLF & _
" Device Binary ID: -" & @CRLF & _
" Device Text ID: -" & @CRLF & _
" Read Only: false" & @CRLF & _
" Fenced Due to Restore: false" & @CRLF & _
" Used Size: 5MB" & @CRLF & _
" Maximum Resize Size: 64.00GB" & @CRLF & _
" Creation Time: 9/14/2016 13:55:09" & @CRLF & _
" Class: regular" & @CRLF & _
" Node Hosting the LUN: node1" & @CRLF & _
" QoS Policy Group: -" & @CRLF & _
" Caching Policy Name: -" & @CRLF & _
" Clone: false" & @CRLF & _
" Clone Autodelete Enabled: false" & @CRLF & _
" Inconsistent Import: false" & @CRLF & _
" Application: -"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")