package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^|\D)\b50\d{7}($|\D)`)
var str = `C 5002454645 500419834`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}