$re = '/(^|\D)\b50\d{7}($|\D)/m';
$str = 'C 5002454645 500419834';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);