import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([\\wÀ-ú\\- ]+( - )[\\wÀ-ú\\- ]+( - )[\\wÀ-ú\\-]+)$";
final String string = "abc - xyz - 123\n"
+ "abc - xyz - 123 - a\n"
+ "- - - - -";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}