re = /^([\wÀ-ú\- ]+( - )[\wÀ-ú\- ]+( - )[\wÀ-ú\-]+)$/m
str = 'abc - xyz - 123
abc - xyz - 123 - a
- - - - -'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end