using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\wÀ-ú ]+ - [\wÀ-ú ]+ - [\wÀ-ú]+$";
string input = @"abc - xyz - 123
abc - xyz - 123 - a
- - - - -";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}