package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\wÀ-ú ]+ - [\wÀ-ú ]+ - [\wÀ-ú]+$`)
var str = `abc - xyz - 123
abc - xyz - 123 - a
- - - - -`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}