re = /^([^-]+ - ){2}[^- ]+$/m
str = 'abc - xyz - 123
abc - xyz - 123 - a
- - - - -
_ - ____ - _
÷÷ - ÷ - ÷÷÷
- - x
-- [^-] pega quebras de linha
abc - fad
fdas - fda'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end