$re = '/[-]?\d+(\.\d+)?/';
$str = '1
-1
1
12
-12
12.5
-12.5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);